Veeam Cloud Connect - ORD6
Incident Report for Deft
Resolved
This incident has been resolved.
Posted Sep 20, 2018 - 00:01 CDT
Identified
We have identified the issue and are working to restore service.
Posted Sep 19, 2018 - 23:48 CDT
Investigating
We are investigating reports of an issue relating to connecting to the Veeam Cloud Connect repository in our Elk Grove Village area data center.
Posted Sep 19, 2018 - 23:42 CDT